This file is indexed.

preinst is in postgresql-9.6 9.6.7-0+deb9u1.

This file is a maintainer script. It is executed when installing (*inst) or removing (*rm) the package.

The actual contents of the file can be viewed below.

 1
 2
 3
 4
 5
 6
 7
 8
 9
10
11
12
13
14
15
16
17
18
#!/bin/sh

set -e

MAJOR_VER="${DPKG_MAINTSCRIPT_PACKAGE#postgresql-}"
CATVERSION="201608131" # set by override_dh_installdeb

case $1 in
    install|upgrade)
        if [ "$2" ]; then
            . /usr/share/postgresql-common/maintscripts-functions
            preinst_check_catversion "$MAJOR_VER" "$CATVERSION"
        fi ;;
esac



exit 0