/usr/src/gcc-4.6/debian/patches/gcc-gfdl-build.diff is in gcc-4.6-source 4.6.4-6ubuntu2.
This file is owned by root:root, with mode 0o644.
The actual contents of the file can be viewed below.
1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 | # DP: Build a dummy s-tm-texi without access to the texinfo sources
--- a/src/gcc/Makefile.in
+++ b/src/gcc/Makefile.in
@@ -3681,27 +3681,9 @@
# \r is not portable to Solaris tr, therefore we have a special
# case for ASCII. We use \r for other encodings like EBCDIC.
s-tm-texi: build/genhooks$(build_exeext) $(srcdir)/doc/tm.texi.in
- $(RUN_GEN) build/genhooks$(build_exeext) \
- $(srcdir)/doc/tm.texi.in > tmp-tm.texi
- case `echo X|tr X '\101'` in \
- A) tr -d '\015' < tmp-tm.texi > tmp2-tm.texi ;; \
- *) tr -d '\r' < tmp-tm.texi > tmp2-tm.texi ;; \
- esac
- mv tmp2-tm.texi tmp-tm.texi
+ cat $(srcdir)/doc/tm.texi.in > tmp-tm.texi
$(SHELL) $(srcdir)/../move-if-change tmp-tm.texi tm.texi
- @if cmp -s $(srcdir)/doc/tm.texi tm.texi; then \
- $(STAMP) $@; \
- elif test $(srcdir)/doc/tm.texi -nt $(srcdir)/doc/tm.texi.in \
- && test $(srcdir)/doc/tm.texi -nt $(srcdir)/target.def; then \
- echo >&2 ; \
- echo You should edit $(srcdir)/doc/tm.texi.in rather than $(srcdir)/doc/tm.texi . >&2 ; \
- false; \
- else \
- echo >&2 ; \
- echo Verify that you have permission to grant a GFDL license for all >&2 ; \
- echo new text in tm.texi, then copy it to $(srcdir)/doc/tm.texi. >&2 ; \
- false; \
- fi
+ $(STAMP) $@
GTFILES = $(CPP_ID_DATA_H) $(srcdir)/input.h $(srcdir)/coretypes.h \
$(srcdir)/vecprim.h $(srcdir)/vecir.h \
|